All Apps and Add-ons

Getting to the Splunk for Unix app

thesteve
Path Finder

I've installed the Splunk for Unix app via the web interface. (fresh splunk 6.1 installation on Ubuntu 14.04 with Splunk for Unix and Linux 5.0.3)

On the home page, I get the link for setup which takes you to the page to enable or disable scripts and inputs.

I don't see how to get to the app. I've installed this before and I remember it being straightforward, I'm missing a step.

If I go to http://localhost:8000/en-US/app/Splunk_TA_nix it just redirects to http://localhost:8000/en-US/app/Splunk_TA_nix/setup. It's the only page I can get to.

Restarting splunk has no effect.

0 Karma
1 Solution

ChrisG
Splunk Employee
Splunk Employee

Sorry to ask the most obvious question, but does the app appear on your Home page or in the Apps list in the upper-left corner of your main Splunk Enterprise view?

View solution in original post

ChrisG
Splunk Employee
Splunk Employee

Sorry to ask the most obvious question, but does the app appear on your Home page or in the Apps list in the upper-left corner of your main Splunk Enterprise view?

View solution in original post

ChrisG
Splunk Employee
Splunk Employee

I just realized that's what you had done, too. I should have noticed that right away from your original posting, my apologies. Good luck!

0 Karma

thesteve
Path Finder

Have you ever had one of those days where your brain isn't working right? I installed the Add-on for Unix/Linux, not the App for Unix/Linux.

ChrisG
Splunk Employee
Splunk Employee

So you have gone through the Your Data settings page and saved the settings. You said it's a clean install, so you should not have needed to configure special index settings. Were you able to preview your data after you configured source types? Did you install the add-on on your forwarders?

0 Karma

thesteve
Path Finder

It does, but it's grey (I remember it being blue) and the only option is "Splunk for Unix Add-on: Setup". I've gone into that page and saved changes, and tried restarting splunk

0 Karma