All Apps and Add-ons

Error in Splunk GitHub Content

Hysteresis
Engager

I'm trying to implement the Splunk Machine Learning Toolkit Query, found here: https://github.com/splunk/security_content/blob/develop/detections/cloud/abnormally_high_number_of_c...

Actually just the first part:

| tstats count as all_changes from datamodel=Change_test where All_Changes.object_category=* All_Changes.status=* by All_Changes.object_category All_Changes.status All_Changes.user

But I'm getting this error

Hysteresis_0-1728404149803.png

 

How do I fix this?

Labels (1)
0 Karma
1 Solution

sainag_splunk
Splunk Employee
Splunk Employee

can you try adding this below line to the end of your search? and give it a try?

| noop search_optimization.predicate_push=f


https://docs.splunk.com/Documentation/SplunkCloud/latest/SearchReference/Noop#Managing_specific_sear...

Hope this Helps. Karma would be appreciated. 

If this helps, Upvote!!!!
Together we make the Splunk Community stronger 

View solution in original post

0 Karma

sainag_splunk
Splunk Employee
Splunk Employee

can you try adding this below line to the end of your search? and give it a try?

| noop search_optimization.predicate_push=f


https://docs.splunk.com/Documentation/SplunkCloud/latest/SearchReference/Noop#Managing_specific_sear...

Hope this Helps. Karma would be appreciated. 

If this helps, Upvote!!!!
Together we make the Splunk Community stronger 
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Guided Onboarding with Auto-schema Is Now Generally Available

  We are excited to announce the General Availability of Guided Onboarding with Auto-Schematization ...

ATTENTION: We’re Moving! (AGAIN!)

The Splunk Community Slack is undergoing a system migration to keep our workspace secure and ...

Deep Dive: Optimizing Telemetry Pipelines in Splunk Observability Cloud

In this session, we will peel back the layers of Splunk Observability Cloud’s cost-optimization features. ...