All Apps and Add-ons

Data Model Network_Traffic doesn't work

ahsaine
New Member

I am new on Splunk. I am using Infosec app and I have question please.
I am getting logs from the firewall after executing this command: | datamodel Network_Traffic All_Traffic search
But the Network_Traffic data model doesn't show any results after this request: | tstats summariesonly=true allow_old_summaries=true count from datamodel=Network_Traffic.All_Traffic where (All_Traffic.action=blocked OR All_Traffic.action=deny)
Any idea how to resolve this??

0 Karma

richgalloway
SplunkTrust
SplunkTrust

The tstats command doesn't like datasets in the datamodel option. Use the nodename option, instead.

... | tstats summariesonly=true allow_old_summaries=true count from datamodel=Network_Traffic where nodename=Network_Traffic.All_Traffic  (All_Traffic.action=blocked OR All_Traffic.action=deny)
---
If this reply helps you, Karma would be appreciated.
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

A Four-Part Event Series: Full Stack Observability For the AI Era

As AI reshapes applications, infrastructure, and the way teams operate, the traditional boundaries of ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...