All Apps and Add-ons

Data Model Network_Traffic doesn't work

ahsaine
New Member

I am new on Splunk. I am using Infosec app and I have question please.
I am getting logs from the firewall after executing this command: | datamodel Network_Traffic All_Traffic search
But the Network_Traffic data model doesn't show any results after this request: | tstats summariesonly=true allow_old_summaries=true count from datamodel=Network_Traffic.All_Traffic where (All_Traffic.action=blocked OR All_Traffic.action=deny)
Any idea how to resolve this??

0 Karma

richgalloway
SplunkTrust
SplunkTrust

The tstats command doesn't like datasets in the datamodel option. Use the nodename option, instead.

... | tstats summariesonly=true allow_old_summaries=true count from datamodel=Network_Traffic where nodename=Network_Traffic.All_Traffic  (All_Traffic.action=blocked OR All_Traffic.action=deny)
---
If this reply helps you, Karma would be appreciated.
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Splunk App Dev Quarterly Roundup: AI, Agents, and Innovation!

Another quarter, another wave of innovation. From complex integrations to pushing the limits ...

Federated Search for Dynamic Data Self Storage Is Now Generally Available on Splunk ...

 Splunk is excited to announce the General Availability of Federated Search for Dynamic Data Self Storage ...

Index This | What has many keys but can’t unlock a door?

July 2026 Edition  Hayyy Splunk Education Enthusiasts and the Eternally Curious!   We’re back with this ...