Getting Data In

Timeparsing issues

walsborn
Path Finder

Hello all,

I'm having a time parsing issue that I don't know how to fix and am looking for some help.

My inputs on the syslog looks like this:

[monitor]
index = *
no_appending_timestamp = true
host_segment = 5
disabled = false

My Props for this source type is configured by a TA.  But the problem I'm having in the logs were from changes in our syslog system.

The new log looks like Dec 14 08:50:19 bxxm-itb.net.xxx.xxx 1,2021/12/14 08:50:18,

How do I configure props to tell splunk to ignore the first timestamp, skip the host fqdn and then parse the second time?

Labels (4)
0 Karma
1 Solution

gcusello
Legend

Hi @walsborn,

you have to add to your props.conf the following options:

[your_sourcetype]
TIME_PREFIX = ,
TIME_FORMAT = %Y/%m/%d %H:%M:%S

Ciao.

Giuseppe

View solution in original post

walsborn
Path Finder

That did it @gcusello , thank you.

0 Karma

gcusello
Legend

Hi @walsborn,

you have to add to your props.conf the following options:

[your_sourcetype]
TIME_PREFIX = ,
TIME_FORMAT = %Y/%m/%d %H:%M:%S

Ciao.

Giuseppe

Get Updates on the Splunk Community!

Splunk Forwarders and Forced Time Based Load Balancing

Splunk customers use universal forwarders to collect and send data to Splunk. A universal forwarder can send ...

NEW! Log Views in Splunk Observability Dashboards Gives Context From a Single Page

Today, Splunk Observability releases log views, a new feature for users to add their logs data from Splunk Log ...

Last Chance to Submit Your Paper For BSides Splunk - Deadline is August 12th!

Hello everyone! Don't wait to submit - The deadline is August 12th! We have truly missed the community so ...