Hello all, we recently migrated some of our legacy dashboards to Dashboard Studio and running into issues with text inputs where the value could be optional. In legacy dashboards, this could be handled by adding a wildcard in the search, but in Dashboard Studio the visualizations refuse to run if there is no value, so we added "*" as the default value. Unfortunately, when the user tabs between the text inputs, Splunk doesn't highlight the field, so they sometimes enter text after the asterisk, causing the search to find ZERO values (really Splunk, really?). My research has not found a simple solution to this issue, so we came up with this. We use a default value of " " for all text inputs. If the user enters anything in a field, Splunk strips the leading space (yay!), but if a blank field is left, Splunk retains the blank space (WTF?). To work around this, we came up with the following search logic to handle the blanks, but at least the dashboard now allows blank inputs as wildcards (just like the legacy dashboards...). | makeresults | eval USER_FIRST_NAME=ltrim("$INPUT_USER_FIRST_NAME$"," ") + "*" | eval USER_LAST_NAME=ltrim("$INPUT_USER_LAST_NAME$"," ") + "*" | eval USER_ID=ltrim("$INPUT_USER_ID$"," ") + "*" | map [ | tstats summariesonly=false count from datamodel=test where User_First_Name="$$USER_FIRST_NAME$$" User_Last_Name="$$USER_LAST_NAME$$" User_Id="$$USER_ID$$" by User_First_Name User_Last_Name User_Id Tenant_Code ] So, here is my actual question. Is there a way in Dashboard Studio to do this properly that I'm just missing? If not, is there another way to manage this without the "map" function as shown above? Not a fan of using this, but we found no other way to make this work. Enquiring minds need to know! Thanks in advance.
... View more