I tried ,
>splunk list monitor
Its shows the list of files & directories that are being monitored, but still cant view the data in SH. also there is no any errors in splunkd log.
... View more
I tried in my windows universal forwarder the script , but cant execute it ,
C:\Program Files\SplunkUniversalForwarder\bin>splunk cmd python "c:\filestatus.py"
CreateProcess: The system cannot find the file specified.
couldn't run "c:\Program Files\SplunkUniversalForwarder\bin\python": The system cannot find the file specified.
... View more
Note: A single dot (.) is not a wildcard, and is the regex equivalent of ..
Caution: In Windows, you cannot currently use a wildcard at the root level. For example, this does not work:
[monitor://E:\...\foo\*.log]
Splunk Enterprise logs an error and fails to index the desired files.
This is a known issue, described in the Known Issues topic of the Release Notes. Look there for details on all known issues.
... View more
I want to monitor XML files residing inside sub-directories.
Files inside Path :
D:\Roll\DIP\SessionLogs\35\1.xml
D:\Roll\DIP\SessionLogs\35\2.xml
D:\Roll\DIP\SessionLogs\35\3.xml
D:\Roll\DIP\SessionLogs\36\1.xml
D:\Roll\DIP\SessionLogs\36\2.xml
D:\Roll\DIP\SessionLogs\36\3.xml
I set inputs.conf: (in Universal forwarder)
[monitor://D:\Roll\DIP\SessionLogs\]
index = myindex
sourcetype = session_log
props.conf (in indexer)
[session_logs]
KV_MODE = xml
I dont get the logs in Search head ? Something am i missing here ..?
... View more
After installing Splunk Universal forwarder in Windows Server ., how to add monitor stanzas for getting windows application , security, system logs via command line ?
>splunk add monitor
... View more
transpose the rows to column values and try with props & transforms.
Key,Date,Value1,Value2
A,Date,5,2
A,Date,6,2
B,Date,1,3
B,Date,6,2
etc..Use ,
|lookup Date as Date Key as Key OUTPUTFIELD Value1,Value2
... View more
I send daily 50 GB raw data from my machines to Splunk for indexing
what will be the size of the data after it got indexed ?
Will this be the same 50 Gb or indexed data will have less size ?
... View more
I have created a savedsearch which displays the Current license usage indexer wise. ("|rest" query)
x- axis : Indexer-1 , Indexer-2, Indexer-3
Y-axis : Amount of Gb indexed .(Eg : 10,20,30,40,50)
I have created a column chart out of this records. Now, I need to add an overlay threshold line in between this column chart.
Warning threshold : 40Gb
Critical threshold : 45Gb
How do i add these horizontal threshold lines in my column chart ?
Please advise
... View more
I tried to tag the field sourcetype as suggested in the link :
[http://docs.splunk.com/Documentation/Splunk/6.1.2/SearchReference/Tags][1]
Examples
Example 1: Write tags for host and eventtype fields into tag::host and tag::eventtype.
... | tags host eventtype
index=* | tags sourcetype
but it doesnt created tag::sourcetype
Please help.. Am i missing something ..?
... View more
"Last 15 minutes" - Is this referring to index time (or) Events time ?
I have hosts located in different timezones, and my Search head & indexers running in GMT TZ.
So,when I do a search for say.,"Last 15 min" , this refers to GMT's timezones last 15 minute ?
I am referring to this since, i might miss data in my search result as host's event time are in their native TZ format which will not be shown for my search
... View more
No there are no duplicate entries in the lookup table.
I tried dedup but it takes the same time..
For a very long time , still the search query is in parsing state.
... View more
I have a lookup table blacklist.csv , which has blacklisted src & dest IPs. Using the below search query , I am listing the events containing blacklisted IPs
index=* sourcetype=pan* [|inputlookup blacklist.csv | fields dest_ip] OR [|inputlookup blacklist.csv | fields src_ip] | table dest_ip,src_ip,status,etc..
My lookup table has 10,000 records, which makes my search slow down. Is there a way optimize the query ?
or any other mechanism to speed up the search ?
... View more
|metadata type=hosts earliest=-1d latest=now
This displays the overall eventcounts for the available hosts but not specific to the time range mentioned.
Is there a way to specify the time range for metadata results ?
... View more
I do need carefully select the selective Warm dbs and move to the new index folder , and check for bucket_id clash. if any I do need to modify the range accordingly and run the below command :
./splunk _internal call /data/indexes/MY-INDX-NAME/rebuild-metadata-and-manifests
doing so, I can be successful in moving the indexed data from one index to another index. (my case i want the data to be searched in the other index name)
Am i fine with the understanding? please correct me , if i am wrong.
... View more
How many number of indexes i can create in an indexer ?
Is there any disadvantages , on too many indexes ?
Keeping all the logs in a single index - would result in performance | slow in processing the search request ?
... View more
Is it possible for me to copy the specific Index bucket to another Index path,
Eg:
I want to copy the indexed data from index name 'My-Index-Name-1' to 'My-Index-Name-2'
Just by cut and copy the bucket to new index path, will work ?
Search query: (will this work , after copy ?)
index=My-Index-Name-2 | table _raw
Details:
Index Name ->My-Index-Name-1
State -> Warm
Path -> /opt/splunk/var/lib/splunk/My-Index-Name-1/db/db_1403947472_1403779602_8
... View more
How does the results of the correlation events go to "notable" index ?
Is there any configuration file for this ?
Also , If i manually call a correlation search , will that results also goes to notable index?
... View more