Splunk Search

top results when using a chart command

rakesh_498115
Motivator

Hi ,

I have query which uses the chart command . Now i need only top ten values to be displayed for that query . used top but didnt get the proper results.

sourcetype="X" | eval a=mvfilter(eventtype LIKE "%_Metrics") |stats count by UniqueID,a |chart sum(count) by UniqueID,a | fillnull value="0"

here a contains the eventtypes

my results are something likethis..

UniqueId A_metrics B_metrics C_metrics
abc 0 56 0
sds 34 5 94
dss 0 53 39
ere 24 45 19
....
...
...

I need to display only the count top 10 UniqueId's..How can i do tat ?? Used top at the bottom but couldnt the same result as above..please help.

Tags (2)
0 Karma
1 Solution

Mahieu
Communicator

Try adding this :
| addtotals | head 5| fields  – Total

View solution in original post

Mahieu
Communicator

Try adding this :
| addtotals | head 5| fields  – Total

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...