Splunk Search

timechart without spaning

sbsbb
Builder

I would like to show the message_types from each event on a timeline.

I think timechart would be the right element, but is there a way to specify that it shoud not span ?

index=t | head 10 | timechart list(H_message_type) [[NOSPAN ?]]

Tags (2)
0 Karma

jonuwz
Influencer

you dont have to use timechart. xyseries can do it too, and you dont specify a span, or an aggregating function

i.e.

index=_internal group="per_sourcetype_thruput"  | xyseries _time series ev

if you dont have a series (a "by" clause - the 2nd arg to xyseries), you need to make a dummy one.

index=_internal | eval wibble="suasages" | xyseries _time wibble bytes
0 Karma

gfuente
Motivator

Hello

Have you tried just:

index=t | head 10 |   timechart count by H_message_type

Regards

0 Karma

MuS
SplunkTrust
SplunkTrust

use this:

index=t | head 10 | timechart span=1ms list(H_message_type)

this should provide the correct chart .... at least it did for me with 5.0.1

cheers, MuS

0 Karma

sbsbb
Builder

splunk is still putting events together... _time difference is in ms...
I tried with span=1cs, but doesn't work :

[SimpleResultsTable module] invalid literal for int() with base 10: '0.01'

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...