Splunk Search

subsearch not returning IP address

Shivs2k
Explorer

I am trying to get a subsearch to return a single value which represents an IP address and I am getting an error "Error in 'eval' command: the number (ip address) is invalid"

 

eval a=
[ search index=pan sourcetype=pan:traffic dest_port=22
| stats count as c by src_ip
| sort - c
| head 1|return $src_ip]

 

any ideas?

Labels (1)
0 Karma
1 Solution

ITWhisperer
SplunkTrust
SplunkTrust

Add format clause

 

eval a=
[ search index=pan sourcetype=pan:traffic dest_port=22
| stats count as c by src_ip
| sort - c
| head 1|return $src_ip|format]

 

View solution in original post

ITWhisperer
SplunkTrust
SplunkTrust

Add format clause

 

eval a=
[ search index=pan sourcetype=pan:traffic dest_port=22
| stats count as c by src_ip
| sort - c
| head 1|return $src_ip|format]

 

Shivs2k
Explorer

thanks, this is cleaner than my solution!

0 Karma

Shivs2k
Explorer

ok I fixed it myself, you have to add quotes to it.

 

eval a=
[ search index=pan sourcetype=pan:traffic dest_port=22
| stats count as c by src_ip
| sort - c
| head 1|eval a="\""+src_ip+"\""|return $a]

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...