Splunk Search

stats question

ken_t_huang
Explorer

Here is my search command:

index="vsapi" | stats dc(guid) as count by os_name, blob_virusinfo_detectionname | sort -count | sort +os_name
  1. how can I output top 50 for "each" os_name?
  2. if I want to add time interval on filename or in csvfile for weekly, how can I set it? (ex: 20110520-20110526-sort_by_osname.csv)

thanks

Tags (3)
0 Karma
1 Solution

dwaddle
SplunkTrust
SplunkTrust

I don't understand your second question, but I think the first one should be pretty easy to do. The built-in top search command supports a by-clause. You can do a | top limit=50 blob_virusinfo_detectionname by os_name (Or whatever other field you with to count the top 50 of by OS). http://www.splunk.com/base/Documentation/latest/SearchReference/Top

View solution in original post

0 Karma

dwaddle
SplunkTrust
SplunkTrust

I don't understand your second question, but I think the first one should be pretty easy to do. The built-in top search command supports a by-clause. You can do a | top limit=50 blob_virusinfo_detectionname by os_name (Or whatever other field you with to count the top 50 of by OS). http://www.splunk.com/base/Documentation/latest/SearchReference/Top

0 Karma

ken_t_huang
Explorer

hi, thanks your reply,
it have show limit 50 for each os_name, but it's not the "top" 50 for count. I need top 50 dc(guid) as count for each os_name.

about second question, I mean when setting seacrh & report, it will send csv file in email, how do I add the query date in filename? (ex: query interval -7d@d -> @d)

regards

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...