Splunk Search

stacked column chart for three values

SanthoshSreshta
Contributor

Hi All,

I have generated a dashboard with column chart using Query: sourcetype="Churn Data_CSV" Churn="True." | stats count(Churn) as "Churn Count" by state |sort - "Churn Count" |head 10

In the above query I used only Churn="True" but now I want to get for TRUE and FALSE for every state showing in stacked column chart.
Can anyone help me out please.?

Regards,
Santhosh S.

0 Karma
1 Solution

SanthoshSreshta
Contributor

Got my answer 🙂

sourcetype="Churn Data_CSV" | stats count(eval(Churn="True.")) as True, count(eval(Churn="False.")) as False,count(eval(Churn="")) as Empty by state | sort - True| head 10

View solution in original post

SanthoshSreshta
Contributor

Got my answer 🙂

sourcetype="Churn Data_CSV" | stats count(eval(Churn="True.")) as True, count(eval(Churn="False.")) as False,count(eval(Churn="")) as Empty by state | sort - True| head 10

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...