Splunk Search

searching on multiple items

jalfrey
Communicator

I have two searches that are very similar and I want to combine the results.

index=sonicwall new_category="Security Services" | stats count(host) by msg host | rename msg as "Warning Message" | rename count(host) as "Total Warnings"

index=sonicwall new_category="Firewall Hardware" | stats count(host) by msg host | rename msg as "Warning Message" | rename count(host) as "Total Warnings"

Seems like I should be able to do something like
index=sonicwall new_category="Firewall Hardware" or new_category="Security Services" but that returns nothing.

Tags (1)
0 Karma
1 Solution

asimagu
Builder

try uppercase OR 😉

View solution in original post

asimagu
Builder

try uppercase OR 😉

jalfrey
Communicator

well that was simple. 🙂

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...