Splunk Search

relating fields with eval

jrich523
Path Finder

I have two fields (different sourcetypes) that have a Node ( for example: node001) and NodeID (example: 1)

How would i extract Node to NodeID dealing with the leading zeros?

Tags (2)
0 Karma
1 Solution

martin_mueller
SplunkTrust
SplunkTrust

First you'll need to search for events from both sourcetypes, then normalize your Node field to match the NodeID field, and then do whatever you're actually trying to do with the data:

  sourcetype=eventsWithNodeID OR sourcetype=eventsWithNode
| rex field=Node "0*(?<tempNodeID>\d+)$" | eval mergedNodeID = case(sourcetype="eventsWithNodeID", NodeID, sourcetype="eventsWithNode", tempNodeID)
| stats values(foo) as foo max(bar) as bar by mergedNodeID

Check out the excellent March 2016 Virtual.conf talk by @sideview on this very subject available at http://wiki.splunk.com/Virtual_.conf

View solution in original post

martin_mueller
SplunkTrust
SplunkTrust

First you'll need to search for events from both sourcetypes, then normalize your Node field to match the NodeID field, and then do whatever you're actually trying to do with the data:

  sourcetype=eventsWithNodeID OR sourcetype=eventsWithNode
| rex field=Node "0*(?<tempNodeID>\d+)$" | eval mergedNodeID = case(sourcetype="eventsWithNodeID", NodeID, sourcetype="eventsWithNode", tempNodeID)
| stats values(foo) as foo max(bar) as bar by mergedNodeID

Check out the excellent March 2016 Virtual.conf talk by @sideview on this very subject available at http://wiki.splunk.com/Virtual_.conf

changux
Builder

Hi. Something like:

sourcetype=X OR sourcetype=Y | rename Node* as *

Can be an option.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...