Splunk Search

multi field grouping

hindla
New Member

Hi Team,

we have a query to get response times from our logs and then do a range to group the Response Time

index=* host=hostname sourcetype=perf*  "*string pattern*"  | rex "GET.*\s(?<resptime>\d+)"   | rangemap field=resptime Lessthan1Sec=0-1000 One_to_ThreeSec=1001-3000 higher_than_three=3001-10000 default="greater_Than_10k" | timechart count by range 

Now, this works fine for one host but unfortunately we want this data for multiple hosts and I am not able to list the time ranges for multiple hosts. Can anyone please help me here.

0 Karma

somesoni2
Revered Legend

Give this a try

 index=* host=hostname sourcetype=perf*  "*string pattern*"  | rex "GET.*\s(?<resptime>\d+)"   | rangemap field=resptime Lessthan1Sec=0-1000 One_to_ThreeSec=1001-3000 higher_than_three=3001-10000 default="greater_Than_10k" | eval host=host.":".range | timechart count by host
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...