Splunk Search

help on date field sorting

jip31
Motivator

hi

the field dv_sys_created_on is a field date

index="tutu" sourcetype="toto" 
| stats last(dv_sys_created_on) as Opened by ticket_id 

i tried to sort it like this but it doesnt works

| eval time = strftime(dv_sys_created_on, "%d-%m-%y %H:%M")
| sort - dv_sys_created_on

could you help please??

 

 

Tags (1)
0 Karma
1 Solution

scelikok
SplunkTrust
SplunkTrust

Hi @jip31,

You are loosing the dv_sys_created_on field on stats command, you can sort like below;

index="tutu" sourcetype="toto" 
| stats last(dv_sys_created_on) as Opened by ticket_id 
| sort - Opened

Or if date field is string below should work better; assuming your date format is "%d-%m-%y %H:%M"

index="tutu" sourcetype="toto" 
| stats last(dv_sys_created_on) as Opened by ticket_id 
| eval time = strptime(Opened, "%d-%m-%y %H:%M")
| sort - time

 

If this reply helps you an upvote and "Accept as Solution" is appreciated.

View solution in original post

0 Karma

ITWhisperer
SplunkTrust
SplunkTrust

What does "the field dv_sys_created_on is a field date" mean? Is it a string in a particular format representing a date? If so, you need to parse the string (the p in strptime means parse, the f in strftime means format) into an epoch datetime (a number) which you can then sort on (strptime, string to number; strftime, number to string)

| eval time = strptime(dv_sys_created_on, "%d-%m-%y %H:%M")
| sort - time

 

0 Karma

scelikok
SplunkTrust
SplunkTrust

Hi @jip31,

You are loosing the dv_sys_created_on field on stats command, you can sort like below;

index="tutu" sourcetype="toto" 
| stats last(dv_sys_created_on) as Opened by ticket_id 
| sort - Opened

Or if date field is string below should work better; assuming your date format is "%d-%m-%y %H:%M"

index="tutu" sourcetype="toto" 
| stats last(dv_sys_created_on) as Opened by ticket_id 
| eval time = strptime(Opened, "%d-%m-%y %H:%M")
| sort - time

 

If this reply helps you an upvote and "Accept as Solution" is appreciated.
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...