Splunk Search

compare two fields and populate missing values

splunklakshman
Explorer

Dear All,
I have a column named called id in file1.csv and id1 in file2.csv .

File1.csv: File2.csv
ID: ID1
1 1
2 2
3

I have loaded into splunk and assign indexes for two files . I have retrieve the extra value 3 from ID(file1.csv) . Can you please help us in writing the splunk search query. Thanks

Tags (1)
0 Karma

woodcock
Esteemed Legend

Like this:

... | eval comboID=coalesce(id, ID, id1, ID1)
| stats values(comboID)
0 Karma

splunklakshman
Explorer

Thanks for your posting your query. I have the fields in two indexes 1) ID in (index=idx_test) and ID1 in (index=idx_test1). Can you please help me in writing complete query. Thanks

0 Karma

splunklakshman
Explorer

I have tried the above query, its displaying 0 records. Thanks

0 Karma

DalJeanis
Legend

Did you correct the index names to be the ones you assigned to your files?

0 Karma

woodcock
Esteemed Legend
index=idx_test OR index=idx_test1
| eval comboID=coalesce(id, ID, id1, ID1)
| stats values(comboID)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...