Splunk Search

command="sendemail", (535, '5.7.3 Authentication unsuccessful') while sending mail to

indeed_2000
Builder

hi i want to use sendmail spl command but it give me below error

command="sendemail", (535, '5.7.3 Authentication unsuccessful') while sending mail to: myemail@mydomain.com

 

my spl command:

index=_internal | head 5 | sendemail to="myemail@mydomain.com" server=mail.server.com subject="Here is an email from Splunk" message="This is an example message" sendresults=true inline=true format=raw sendpdf=true

 
 

FYI:email setting from web server configuration already set correctly, and i test it with alert and send email correctly, but when i use sendmail spl command not work!

 

also i check config file it set correctly:

/opt/splunk/etc/system/local/alert_actions.conf

 

any idea?

thanks,

Labels (4)
Tags (4)
0 Karma
1 Solution

indeed_2000
Builder

after some workaround solved, server not joined to the domain. I write my username with domain, it fixed.

myuser@domain.com

View solution in original post

0 Karma

indeed_2000
Builder

after some workaround solved, server not joined to the domain. I write my username with domain, it fixed.

myuser@domain.com

View solution in original post

0 Karma

PickleRick
Champion

It's easiest to check with the email server's admin but I'd say that sendemail command doesn't authenticate itself.

0 Karma

PickleRick
Champion

This is a response from the server you're trying to use to send mail through. For some reason it's not letting you do it. You should ask the admin of  that server why.

0 Karma

indeed_2000
Builder

alert and sendmail using same method, what is different?

0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!