Splunk Search

Using lookup table within tstats

losttranslation
New Member

Hi All,

I am attempting to use lookup table "is_windows_system_file"  for the following SPL where the Processes.process_name needs to match the filename from the lookup table. Once these results are obtained I then want to attempt to see processes that are not running from C:\Windows\System32 or C:\Windows\SysWOW64 

 

| tstats `summariesonly` count from datamodel=Endpoint.Processes where Processes.process_name=* by Processes.aid Processes.dest Processes.process_name Processes.process _time

 



Labels (4)
0 Karma

richgalloway
SplunkTrust
SplunkTrust

As I understand it, you want the tstats command to look only for process names in the lookup file.  You can do that with a subsearch

| tstats `summariesonly` count from datamodel=Endpoint.Processes where [|inputlookup is_windows_system_file" 
  | fields filename 
  | rename filename as "Processes.process_name" 
  | format] by Processes.aid Processes.dest Processes.process_name Processes.process _time

 

---
If this reply helps you, Karma would be appreciated.
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Index This | What travels the world but is also stuck in place?

April 2026 Edition  Hayyy Splunk Education Enthusiasts and the Eternally Curious!   We’re back with this ...

Discover New Use Cases: Unlock Greater Value from Your Existing Splunk Data

Realizing the full potential of your Splunk investment requires more than just understanding current usage; it ...

Continue Your Journey: Join Session 2 of the Data Management and Federation Bootcamp ...

As data volumes continue to grow and environments become more distributed, managing and optimizing data ...