Splunk Search

Tstats: How to Include new field?

alex4
Loves-to-Learn Lots

I want to use the new search signature="test" in the below search.

I don't want to add this new signature to the existing lookup.

 

 

| tstats summariesonly=true values  (IDS_Attacks.action) as action 
    from datamodel=Intrusion_Detection.IDS_Attacks 
    by _time, IDS_Attacks.src, IDS_Attacks.dest, IDS_Attacks.signature 
| `drop_dm_object_name(IDS_Attacks)`
| lookup rq_subnet_zones Network as dest OUTPUTNEW Name, Location
| lookup rq_subnet_zones Network as src OUTPUTNEW Name, Location
| search NOT Name IN ("*Guest*","*Mobile*","*byod*","*visitors*","*phone*")
| lookup rq_emergency_signature_iocs_v01 ioc as signature OUTPUTNEW last_seen 
| where isnotnull(last_seen) 
| dedup src 
| head 51

 

Labels (1)
Tags (1)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Kick the Tires Before You Commit: A Hands-On Tour of the Splunk Observability Cloud ...

Evaluating an enterprise observability platform usually goes like this: fill out a form, get a free trial with ...

Deep insights, no barriers: Splunk Observability Cloud Free Edition

As software delivery cycles continue to accelerate, observability shouldn’t be a luxury — it should be a ...

Monitoring AI Agents with Splunk Observability Cloud

Let’s say I’m running a travel planning AI app in production. A user asks for three concise hotel options in ...