Splunk Search

Tstats: How to Include new field?

alex4
Loves-to-Learn Lots

I want to use the new search signature="test" in the below search.

I don't want to add this new signature to the existing lookup.

 

 

| tstats summariesonly=true values  (IDS_Attacks.action) as action 
    from datamodel=Intrusion_Detection.IDS_Attacks 
    by _time, IDS_Attacks.src, IDS_Attacks.dest, IDS_Attacks.signature 
| `drop_dm_object_name(IDS_Attacks)`
| lookup rq_subnet_zones Network as dest OUTPUTNEW Name, Location
| lookup rq_subnet_zones Network as src OUTPUTNEW Name, Location
| search NOT Name IN ("*Guest*","*Mobile*","*byod*","*visitors*","*phone*")
| lookup rq_emergency_signature_iocs_v01 ioc as signature OUTPUTNEW last_seen 
| where isnotnull(last_seen) 
| dedup src 
| head 51

 

Labels (1)
Tags (1)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...

Introducing the 2026 - 2027 SplunkTrust cohort!

The goal of the SplunkTrust™ membership has historically been to acknowledge and recognize those who go above ...

Splunk Auto Ingestion Parallel Pipeline Scaling

Why this feature matters Many Splunk environments experience ingestion pressure long before the host is fully ...