Splunk Search

Trying to change date

maheshsat
Explorer

index=_internal | eval Mahesh=replace(date, "^(\d{1,2})/(\d{1,2})/", "\2/\1/")

My date 03-16-2018 I need 16-03-2018

Tags (1)
0 Karma
1 Solution

elliotproebstel
Champion

I notice that your sample dates have dashes, while your attempted regex uses slashes. How about this:

index=_internal
| eval Mahesh=replace(date, "^(\d{1,2})-(\d{1,2})-", "\2/-1-")

View solution in original post

0 Karma

maheshsat
Explorer

Thanks It did work but small correction, below correct syntex.

index=_internal | eval Mahesh=replace(Date, "^(\d{1,2})-(\d{1,2})-"," \2-\1-")

0 Karma

elliotproebstel
Champion

I notice that your sample dates have dashes, while your attempted regex uses slashes. How about this:

index=_internal
| eval Mahesh=replace(date, "^(\d{1,2})-(\d{1,2})-", "\2/-1-")
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...