Splunk Search

Transitive Transaction attributes

bleinfelder
Path Finder

Hi there,

I'm doing analysis on file transfer logs from different transfer system. I want to follow the file through the different systems, and unfortunately they change their names every now and then. Meanwhile I normalized all the relevant fields, so I have events like that:

sourcefile=aafile destfile=aafile

sourcefile=aafile destfile=bbfile

sourcefile=bbfile destfile=ccfile

sourcefile=ccfile destfile=ddfile

I want all these events grouped into one transaction. So far, with " | transaction sourcefile destfile", whenever the filename changes, a new transaction starts.

I found similar questions here, but no answer. Any help?

Regards,

Bernd

Tags (1)
0 Karma
1 Solution

bleinfelder
Path Finder

Hi there,

I found a solution for this: Create a multivalued field that contains sourcefile and destfile and make the transaction with that field:

sourcetype=mysourcetype| eval txattrib=mvappend(sourcefile,null,destfile) | transaction txattrib

With that expression, all four events are grouped to one transaction.

Regards,

Bernd

View solution in original post

0 Karma

bleinfelder
Path Finder

Hi there,

I found a solution for this: Create a multivalued field that contains sourcefile and destfile and make the transaction with that field:

sourcetype=mysourcetype| eval txattrib=mvappend(sourcefile,null,destfile) | transaction txattrib

With that expression, all four events are grouped to one transaction.

Regards,

Bernd

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...