Splunk Search

Swap field and values

muebel
SplunkTrust
SplunkTrust

I have a list of fields within a Datamodel collected as values within the field named "unknown"

| datamodel Authentication Authentication 
| table * 
| spath 
| table fields{}.displayName 
| rename fields{}.displayName as unknown 
| mvexpand unknown

This gives:
alt text

I'd like to extend this search to give me a table with fields "dest_bunit", "dest_category" etc, all with a value of "unknown"

Ultimately this would be used as a subsearch within tstats to find events that have unknown values for any of the values within the datamodel.

More straightforward (and equally dynamic) would probably serve as an answer to this as well.

Tags (3)
0 Karma
1 Solution

somesoni2
Revered Legend

Try like this

| datamodel Authentication Authentication 
 | table * 
 | spath 
 | table fields{}.displayName 
 | rename fields{}.displayName as unknown 
 | mvexpand unknown | eval temp=1 | eval data="unknown" | xyseries temp unknown data | fields - temp

View solution in original post

somesoni2
Revered Legend

Try like this

| datamodel Authentication Authentication 
 | table * 
 | spath 
 | table fields{}.displayName 
 | rename fields{}.displayName as unknown 
 | mvexpand unknown | eval temp=1 | eval data="unknown" | xyseries temp unknown data | fields - temp

muebel
SplunkTrust
SplunkTrust

I had thought that xyseries and/or untable had something to do with the solution. I need to understand those commands better. Thanks!

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...