Splunk Search

Splunk V 6 error Search query is not fully resolved.

ericasmith411
New Member

Good Afternoon,
I am new to Splunk and have a query that is working fine in the search but once saved in the Dashboard it errors out with "Search Query is not Fully Resolved." Anyone have any ideas on what it might be? Thanks for your help in advance.

index=main sourcetype=index=main sourcetype="wineventlog:security" ("EventCode=4776" AND Keywords="Audit Failure") OR ("EventCode=680" AND "Failure Audit") NOT (Logon_Account="$" OR Logon_account="*$") | eval "User Account" = coalesce(Logon_Account,Logon_account)| top limit=20 host

0 Karma

lukejadamec
Super Champion

This in the beginning of the search would give me a headache if I was Splunk:

index=main sourcetype=index=main

Change it to:

index=main sourcetype="wineventlog:security"

0 Karma

somesoni2
Revered Legend

Yes, two $ sign make splunk think its a token. see following post,
http://answers.splunk.com/answers/114841/search-query-is-not-fully-resolved-when-using-a-in-a

ericasmith411
New Member

Thanks for catching that but it was a copy paste error. I am still getting the same error message. I have chopped apart the query and it seems to be something with the "NOT (Logon_Account="$" OR Logon_account="$")" part. Any ideas?

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Modernize your Splunk Apps – Introducing Python 3.13 in Splunk

We are excited to announce that the upcoming releases of Splunk Enterprise 10.2.x and Splunk Cloud Platform ...

Step into “Hunt the Insider: An Splunk ES Premier Mystery” to catch a cybercriminal ...

After a whole week of being on call, you fell asleep on your keyboard, and you hit a sequence of buttons that ...