Splunk Search

Splunk Search: Lateral Movement

johann2017
Explorer

Hello! I am wanting to build a search that can help detect lateral movement. I want to see when the same user is logging into multiple machines in a specific period of time. For example, an admin account gets compromised. That same admin account was then used to log into 50 different computers in the course of an hour. How would I run a search similar to something like that?

Tags (1)
0 Karma

sduff_splunk
Splunk Employee
Splunk Employee

Something like the following would count the number of unique hostnames ( dc = distinct count) that the Admin has logged into.

index=wineventlog Logon user=Administrator earliest=-65m@m | stats dc(hostname), values(hostname)

You may also want to look at the Security Essentials app, https://splunkbase.splunk.com/app/3435/ , which hassome examples of such searches and use-cases.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

New Release of Federated Search: Bringing Splunk Analytics to More of Your Data

Organizations today are generating more data than ever and storing it across cloud object stores, data lakes, ...

Inside Event Intelligence: How ITSI Turns Network Alerts into Actionable Incidents

Tech Talk Inside Event Intelligence: How ITSI Turns Network Alerts into Actionable Incidents   Correlating ...

Observability Simplified: Combining User Experience, Application Performance & ...

  Tech Talk Network to App: Observability Unlocked   Today’s digital environments span applications, ...