Splunk Search

Splunk Ingestion by Day

scout29
Path Finder

I am trying to create a bar chart that shows the total daily splunk ingestion (in TB) by day for the past month. I am using the below search, but i am not able to get the |timechart to work to display the total ingestion by day. What am i missing?

index=_internal source="/opt/splunk/var/log/splunk/license_usage.log" type=Usage idx=* | stats sum(b) as usage
| eval usage=round(usage/1024/1024/1024) | eval usage = tostring(Used, "commas")



0 Karma

scelikok
SplunkTrust
SplunkTrust

There is a typo on @richgalloway's suggestion, please try below;

index=_internal source="/opt/splunk/var/log/splunk/license_usage.log" type=Usage idx=* 
| timechart span=1d sum(b) as usage
| eval usage=round(usage/1024/1024/1024) 
| eval usage = tostring(usage, "commas")

 

If this reply helps you an upvote and "Accept as Solution" is appreciated.

richgalloway
SplunkTrust
SplunkTrust

Replace stats in the query with timechart and it should work.

index=_internal source="/opt/splunk/var/log/splunk/license_usage.log" type=Usage idx=* 
| timechart span=1d sum(b) as usage
| eval usage=round(usage/1024/1024/1024) 
| eval usage = tostring(Used, "commas")

 

---
If this reply helps you, Karma would be appreciated.
0 Karma

PickleRick
SplunkTrust
SplunkTrust

You're doing stats aggregation to a single value. Your stats sum(b) will produce just one overall number.

0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @scout29 ,

see in the Monitoring Console App or in [Settins > License < License Conuption Report > previous 30 days] and you'll have your search.

ciao.

Giuseppe

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...