Splunk Search

Show only null result

Miguel3393
Path Finder

How can I make it show me only what appears as null in the Call.CallForwardInfo.OriginalCalledAddr field? Right now I have this result, you can help me.

Miguel3393_0-1730763112563.png

 

Labels (2)
Tags (4)
0 Karma

zksvc
Contributor

Maybe you can add all your condition in 1 line ? 

| where isnull(cliente) AND isnull(cliente1) AND Call.CallForwardInfo.OriginalCalledAddr="null"

 Let me know if it works

0 Karma

Miguel3393
Path Finder

Hi,

It was added in the following way and it did not work, it does not show results.

index="cdr_cfs_index"
| search Call.OrigParty.TrunkGroup.TrunkGroupId=2601
| lookup ClientesSymSipdfntion1 Call.OrigParty.CallingPartyAddr OUTPUT cliente
| lookup ClientesSymSipdfntion2 Call.OrigParty.CallingPartyAddr OUTPUT cliente1
| fillnull value=null Call.CallForwardInfo.OriginalCalledAddr | where isnull(cliente) AND isnull(cliente1) AND Call.CallForwardInfo.OriginalCalledAddr="null"
| stats count by Call.OrigParty.CallingPartyAddr Call.CallForwardInfo.OriginalCalledAddr
| sort - Call.CallForwardInfo.OriginalCalledAddr

Miguel3393_0-1730783461497.png

 

 

0 Karma

richgalloway
SplunkTrust
SplunkTrust

Add | where Call.CallForwardInfo.OriginalCalledAddr="null" to the query.

---
If this reply helps you, Karma would be appreciated.
0 Karma

Miguel3393
Path Finder

I added it but it doesn't work, it doesn't show results.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...