Splunk Search

Show multiple machines for lockouts

Ewong
Explorer

Hi all,

A past consultant of ours wrote the following correlation search to detect excessive user account lockouts:

index=wineventlog EventCode=4740| stats count min(_time) as firstTime max(_time) as lastTime by user, signature | `ctime(firstTime)` | `ctime(lastTime)` | search count > 5

 

The results display the following:

usersignaturecountfirstTimelastTime
<user name>A user account was locked out<count>01/07/2021 07:57:1001/14/2021 02:56:51

 

The count above is a total of lockouts from different machines in our environment over a period of time.

 

How can I add an additional column to list the actual machine names causing the lockouts (this data would be taken from the particular field "dest_nt_domain") And is there a better way of doing this?

ie)

usersignaturecountfirstTimelastTimemachines
<user name>A user account was locked out<count>01/07/2021 07:57:1001/14/2021 02:56:51<computer1>, <computer2>, ...

 

Labels (2)
0 Karma
1 Solution

scelikok
SplunkTrust
SplunkTrust

Hi @Ewong,

Please try below;

index=wineventlog EventCode=4740 
| stats count min(_time) as firstTime max(_time) as lastTime values(dest_nt_domain) as machines by user, signature 
| `ctime(firstTime)` 
| `ctime(lastTime)` 
| search count > 5

 

If this reply helps you an upvote is appreciated.

If this reply helps you an upvote and "Accept as Solution" is appreciated.

View solution in original post

richgalloway
SplunkTrust
SplunkTrust

Try this

index=wineventlog EventCode=4740| stats count min(_time) as firstTime max(_time) as lastTime, values(dest_nt_domain) as machines by user, signature | `ctime(firstTime)` | `ctime(lastTime)` | search count > 5
---
If this reply helps you, Karma would be appreciated.
0 Karma

Ewong
Explorer

That worked remarkably, thank you!

0 Karma

scelikok
SplunkTrust
SplunkTrust

Hi @Ewong,

Please try below;

index=wineventlog EventCode=4740 
| stats count min(_time) as firstTime max(_time) as lastTime values(dest_nt_domain) as machines by user, signature 
| `ctime(firstTime)` 
| `ctime(lastTime)` 
| search count > 5

 

If this reply helps you an upvote is appreciated.

If this reply helps you an upvote and "Accept as Solution" is appreciated.
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Why Splunk Customers Should Attend Cisco Live 2026 Las Vegas

Why Splunk Customers Should Attend Cisco Live 2026 Las Vegas     Cisco Live 2026 is almost here, and this ...

What Is the Name of the USB Key Inserted by Bob Smith? (BOTS Hint, Not the Answer)

Hello Splunkers,   So you searched, “what is the name of the usb key inserted by bob smith?”  Not gonna lie… ...

Automating Threat Operations and Threat Hunting with Recorded Future

    Automating Threat Operations and Threat Hunting with Recorded Future June 29, 2026 | Register   Is your ...