Splunk Search

Search result count

alexspunkshell
Contributor

I have 10 indexes starts with "ep_winevt_ms" . So i am using * here "index=ep_winevt_ms*".

But while taking the | stats count i want only 1 count for the entire "ep_winevt_ms*". I don't want 10 count for "ep_winevt_ms*". Please help

Labels (4)
0 Karma

ITWhisperer
SplunkTrust
SplunkTrust

| stats count will give you the count of events returned by the search of all the ep_winevt_ms* indexes.

Why do you think this is not the case?

0 Karma

alexspunkshell
Contributor

ep_winevt_ms* - This index is mapped in Data Model Macros.  

I want to exclude all other indexes in (ep_winevt_ms*) and take the count as 1 to know the unique indexes.

@ITWhisperer 

0 Karma

ITWhisperer
SplunkTrust
SplunkTrust
| stats count by index
| stats count
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...