Splunk Search

Search Question: Event Sampling

adalbor
Builder

Does anyone know of a good way to pull one event of a specific eventcode/type when searching for multiple eventcodes?

It doesn't appear that event sampling can do something like that.

I was hoping to run a search for all Windows EventCodes and to only return one event of each type.

Is that possible?

Thanks,
Andrew

0 Karma
1 Solution

niketn
Legend

@adalbor for the community to assist you better can you please add more details? What are the fields you have/are interested in and what is does your current SPL/data looks like?

Can you try one of the following?

<yourSearchToPullData>
| dedup EventCode
| table EventCode *

Or with stats

<yourSearchToPullData>
| stats latest(*) as * by EventCode
____________________________________________
| makeresults | eval message= "Happy Splunking!!!"

View solution in original post

0 Karma

niketn
Legend

@adalbor for the community to assist you better can you please add more details? What are the fields you have/are interested in and what is does your current SPL/data looks like?

Can you try one of the following?

<yourSearchToPullData>
| dedup EventCode
| table EventCode *

Or with stats

<yourSearchToPullData>
| stats latest(*) as * by EventCode
____________________________________________
| makeresults | eval message= "Happy Splunking!!!"
0 Karma

adalbor
Builder

That was too easy! Thank you!
I used
index=wineventlog
| dedup EventCode
| table EventCode,Message

0 Karma

niketn
Legend

@adalbor I have converted my comment to answer. Please accept to mark this question as answered. Also, if you have used dedup also add fields before dedup to retain only the fields you are interested in.

 index=wineventlog
 | fields EventCode Message
 | dedup EventCode
 | table EventCode Message
____________________________________________
| makeresults | eval message= "Happy Splunking!!!"
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Data Management Digest – May 2026

Welcome to the May 2026 edition of Data Management Digest!   As your trusted partner in data innovation, the ...

Index This | What is feather-light but cannot be held long?

May 2026 Edition  Hayyy Splunk Education Enthusiasts and the Eternally Curious!   We’re back with this ...

.conf26 Registration is Live: Secure Your Early Bird Pass Now

  Lock in Your Spot: Registration Open for .conf26 in Denver Hello Splunkers, I have exciting news! Your ...