Splunk Search

Same Column Value Difference

reverse
Contributor
C1 C2
A 12
A 120
B 45
B 78
C 98
C 90
D 0
D 86

how to find difference in values of C2 for every same C1 value

Tags (1)
0 Karma
1 Solution

vnravikumar
Champion

Hi

Try this

source="diff.csv" host="ind1" sourcetype="csv" 
| table C1 C2 
| sort C1 
| stats values(C2) as C2 by C1 
| eval num1 = mvindex(C2,0) 
| eval num2 = mvindex(C2,1) 
| eval diff = num2-num1 
| table C1,C2,diff

View solution in original post

0 Karma

vnravikumar
Champion

Hi

Try this

source="diff.csv" host="ind1" sourcetype="csv" 
| table C1 C2 
| sort C1 
| stats values(C2) as C2 by C1 
| eval num1 = mvindex(C2,0) 
| eval num2 = mvindex(C2,1) 
| eval diff = num2-num1 
| table C1,C2,diff
0 Karma

reverse
Contributor

It worked!!!

Thank you !!!.. but what if there are multiple As Bs Cs and Ds
As of now this solution is perfect for 2 same values.

0 Karma

reverse
Contributor

@vnravikumar can we make a generic solution ?

0 Karma

reverse
Contributor

@Vijeta @jnudell_2 You around folks ?

0 Karma

reverse
Contributor

@Vijeta Please guide.

0 Karma

vnravikumar
Champion

Example, please

0 Karma

reverse
Contributor

It is there ..

C1 C2
A 12
A 120
B 45
B 78
C 98
C 90
D 0
D 86
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...