Splunk Search

SPLUNK architecture

Jeronimo317
Explorer

Hi, I am very new to SPLUNK and inherited an environment without much documentation. Can anyone help with the following queries. 

  1. List of all UF hosts and the HF each of them forwards to
  2. List of all HF and the Indexer each of them forwards to
  3. List of all indexers  

Thank you .

Labels (1)
0 Karma

yannK
Splunk Employee
Splunk Employee

Here is the Guide you need :

https://docs.splunk.com/Documentation/Splunk/8.0.5/InheritedDeployment/Introduction

 

 

Now you can figure much by just looking at the internal logs.

 

indexers : look at the splunk_server field, it tells you on which indexer the data is stored.

index=_internal | stats dc(host) count by splunk_server


heavy forwarders / forwarders : look at the metrics logs, and identify who it sending data to who , and look at the fwdType field.

index=_internal source=*metrics.log* group=tcpin_connections fwdType=*
| stats dc(hostname) values(version) values(os) by fwdType

 

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...