Splunk Search

Restrict search terms & tstats

ccsfdave
Builder

Greetings,

I have a dashboard panel the runs the following:

| tstats sum(bytes_sent) AS sumSent sum(bytes_received) AS sumReceived FROM pan_traffic groupby _time span=5m | timechart span=5m values("sumReceived") AS "Bytes Received" values("sumSent") AS "Bytes Sent"

Groups with restricted search terms access this dashboard but their restrictions (on IP subnets) do not trigger and thus they can see all the results.

Is there anything I can do about this?

Thanks!

0 Karma
1 Solution

ccsfdave
Builder

The issue here was the user didn't have access to the data I was reporting on because the data was in a different Splunk app. Once I granted access to that app, everything worked.

It would be nice to be able to share data between apps w/o granting access to the app directly.

View solution in original post

ccsfdave
Builder

The issue here was the user didn't have access to the data I was reporting on because the data was in a different Splunk app. Once I granted access to that app, everything worked.

It would be nice to be able to share data between apps w/o granting access to the app directly.

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...