Splunk Search

Regex: subpattern name expected

robprice797
New Member
org_name="myOrg" index="myIndex" app_name="myAppName" space_name="Staging"
| rex field=msg "stack:(?<.*java\.lang.*Exception.*>\S+) "
| eval earliest=_time-1
| eval latest=_time+1
| cluster t=0.9 showcount=t 
| head 20 
| spath msg
| table timestamp,_time,stack,msg 
| sort -timestamp
| reverse

I get the error:

Error in 'rex' command: Encountered the following error while compiling the regex 'stack:(?<.*java\.lang.*Exception.*>\S+) ': Regex: subpattern name expected

Can someone help?

Tags (2)
0 Karma

woodcock
Esteemed Legend

Try this:

index="myIndex" org_name="myOrg" app_name="myAppName" space_name="Staging"
| rex field=msg "(?<stack>.*java\.lang.*Exception.*\S+)"
| eval earliest=_time-1
| eval latest=_time+1
| cluster t=0.9 showcount=t 
| head 20 
| spath msg
| table timestamp,_time,stack,msg 
| sort -timestamp
| reverse

I am assuming that you are trying to create a field called stack but I have no idea what the rest of the RegEx should be. If this is not correct, expand on this:
https://regex101.com/r/HdGXie/1

0 Karma

chrisyounger
SplunkTrust
SplunkTrust

Try this:

org_name="myOrg" index="myIndex" app_name="myAppName" space_name="Staging"
| rex field=msg "(?<stack>java.lang.Exception.\S+)"
| eval earliest=_time-1
| eval latest=_time+1
| cluster t=0.9 showcount=t 
| head 20 
| spath msg
| table timestamp,_time,stack,msg 
| sort -timestamp
| reverse
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...