Splunk Search

Query to capture distinct source IP who triggered multiple signatures

sumit29
Path Finder

Dear Experts,

I require help to create the query.
I am creating the rule if single(unique) source triggered distinct signature(more than 2) . Than only we should get the result.

Fields involved src,signature,count

Thanks in advance

Tags (1)
0 Karma
1 Solution

dcarmack_splunk
Splunk Employee
Splunk Employee

Gotcha. Try this for your stats then.

... | stats values(signature) as signatures by src | eval sig_count=mvcount(signature) | where sig_count >= 2

View solution in original post

0 Karma

dcarmack_splunk
Splunk Employee
Splunk Employee

Gotcha. Try this for your stats then.

... | stats values(signature) as signatures by src | eval sig_count=mvcount(signature) | where sig_count >= 2

0 Karma

sumit29
Path Finder

Thanks :)....

0 Karma

dcarmack_splunk
Splunk Employee
Splunk Employee

no problem, glad to help!

0 Karma

dcarmack_splunk
Splunk Employee
Splunk Employee

index= sourcetype= | fields src signature | stats count by src signature | where count >= 2

0 Karma

sumit29
Path Finder

Thanks, But this query only gives signature count along with src , I require count of signature from single source.

Let say source 10.10.10.10 trigger signature name = x and another signature name =y . so this source triggered 2 distinct signature . This what i am looking

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

[Puzzles] Solve, Learn, Repeat: Tiling

This puzzle (first published here) is based on finding groups of tessellated tiles (inspired by floor tiles I ...

SOK it to Me: Top 3 Benefits of Using Splunk Operator on Kubernetes that’ll Make ...

    Thursday, July 9, 2026  |  11:00AM–12:00PM PDT Duration: 1 hour (includes Q&A) Managing can feel like a ...

Upgrade Prep for 10.4, Network Observability Deep Dives, and More from Splunk Lantern

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...