Splunk Search

Please Help

sumitp10797
New Member

   Provide details about client purchase details 

         1. Total purchase split by product ID

         2. Total Products split by product ID 

with raw data

Labels (1)
0 Karma

ashvinpandey
Contributor

@sumitp10797 Try using below queries:

1. Total purchase split by product ID

index=<<your_index> sourcetype=<<your_sourcetype>>
| stats sum(purchase_field) as purchase by product_id

2. Total Products split by product ID 

index=<<your_index> sourcetype=<<your_sourcetype>>
| stats sum(products_field) as products by product_id

3. Both Combined Query:

index=<<your_index> sourcetype=<<your_sourcetype>>
| stats sum(purchase_field) as purchase sum(products_field) as products by product_id

Also, if this reply helped you in solving your problem an up-vote would be appreciated.

ashvinpandey
Contributor

@sumitp10797 Also if you received you answer please mark it as a solution so that I can be used by others for a reference.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...