Splunk Search

Need help for Predict command

dhavamanis
Builder

Need your help,

We need to get the prediction for each business unit and sub business unit. But the below query giving the overall business unit prediction. Please provide the working example to get each business unit and sub business unit wise split-up for next 3 month prediction.

index="akamai-bill" |stats sum(BU_Total) as "cost($)" by _time, BU, SBU | predict "cost($)" algorithm=LLT future_timespan=3 | sort + SBU +BU

0 Karma
1 Solution

dhavamanis
Builder

using map command able to filter the results,

index="akamai-bill" |table BU, SBU| map search="search index="akamai-bill" SBU=$SBU$ |stats sum(BU_Total) as "cost" by _time, SBU | predict "cost" algorithm=LLT future_timespan=3 | table _time, SBU,lower95(prediction(cost)) ,prediction(cost),upper95(prediction(cost)) | eval SBU=if(SBU=$SBU$, $SBU$,$SBU$."1") | table _time, SBU,lower95(prediction(cost)) ,prediction(cost),upper95(prediction(cost)) | where SBU!=$SBU$ | table _time, SBU,lower95(prediction(cost)) ,prediction(cost),upper95(prediction(cost)) | eval SBU=$SBU$ "

View solution in original post

0 Karma

dhavamanis
Builder

using map command able to filter the results,

index="akamai-bill" |table BU, SBU| map search="search index="akamai-bill" SBU=$SBU$ |stats sum(BU_Total) as "cost" by _time, SBU | predict "cost" algorithm=LLT future_timespan=3 | table _time, SBU,lower95(prediction(cost)) ,prediction(cost),upper95(prediction(cost)) | eval SBU=if(SBU=$SBU$, $SBU$,$SBU$."1") | table _time, SBU,lower95(prediction(cost)) ,prediction(cost),upper95(prediction(cost)) | where SBU!=$SBU$ | table _time, SBU,lower95(prediction(cost)) ,prediction(cost),upper95(prediction(cost)) | eval SBU=$SBU$ "

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...