Splunk Search

Multiply value by 100.

deanamite91
Explorer

I have the following search

index="commercial_performance"  Cat1="Unit Cost Modelled Standard Activity Rate" Value!="within *" $month_token$ $Customer_token$ $SL_token$ | stats avg(Value) AS "Planned" by Cat      
| appendcols [search index="commercial_performance"  Cat1="Unit Cost Actual" Value!="within *" $month_token$ $Customer_token$ $SL_token$ | stats avg(Value) AS "Actual" by Cat]

I want to multiply 'Value' by 100. How do I do this?

Tags (2)
0 Karma

richgalloway
SplunkTrust
SplunkTrust

Try this:

... | eval Value=Value*100 | stats avg(Value) ...

You'll need the eval command in both your main search and in the subsearch.

---
If this reply helps you, Karma would be appreciated.
0 Karma

somesoni2
Revered Legend

Try this

index="commercial_performance"  Cat1="Unit Cost Modelled Standard Activity Rate" Value!="within *" $month_token$ $Customer_token$ $SL_token$  | eval Value=Value*100 | stats avg(Value) AS "Planned" by Cat      
 | appendcols [search index="commercial_performance"  Cat1="Unit Cost Actual" Value!="within *" $month_token$ $Customer_token$ $SL_token$ | eval Value=Value*100 | stats avg(Value) AS "Actual" by Cat]

OR

index="commercial_performance"  Cat1="Unit Cost Modelled Standard Activity Rate" Value!="within *" $month_token$ $Customer_token$ $SL_token$ | stats avg(Value) AS "Planned" by Cat      
 | appendcols [search index="commercial_performance"  Cat1="Unit Cost Actual" Value!="within *" $month_token$ $Customer_token$ $SL_token$ | stats avg(Value) AS "Actual" by Cat] | eval Planned=Planned*100 | eval Actual=Actual*100
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...