Splunk Search

Multi-Axis timechart

schlapfer
New Member

I am wanting to timechart total logins, login failures, and failure rate on a mult-axis graph. So time across the bottom, with total logins/login failures stacked and shown on 1 y-axis, and the failure rate percentage on the other y-axis. I can calculate the 3 values with the following search ... just not sure how to do the timechart with multi-axis for the logins and percentage series.

index=logins | stats count(eval(Login_Result="FAILED")) AS failed, count(eval(Login_Result)) AS total_logins | eval failure_rate=((failed/total_logins)*100) | eval failure_rate=round(failure_rate,2)

Tags (1)
0 Karma

alacercogitatus
SplunkTrust
SplunkTrust

index=logins | bin _time span=10m | stats count(eval(Login_Result="FAILED")) AS failed, count(eval(Login_Result)) AS total_logins by _time | eval failure_rate=round(((failed/total_logins)*100),2)

This should give you some time-based data to graph with. A Column Chart might work.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...