Splunk Search

Lookup missing definition

victornajduch
Loves-to-Learn Everything

Good afternoon, 

I can't make sense of why I can't extract a definition from a particular csv. 
I doublechecked permissions and verified that all of my columns are appearing via | inputlookup file.csv | table loopback, device

the output recognizes both the custom device data as well as loopback but if I attempt to table the info "device" is not recognized. 

index=index "syslog message"
| rex field=_raw "peer (?<neighbor>\d+.\d+.\d+.\d+.)" | dedup neighbor

| lookup xo-access-loopback loopback as neighbor output device | table device, neighbor

I get neighbor output but not device. 
csv looks like - 
Any ideas?

deviceloopback
routernamex.x.x.x
Labels (1)
Tags (1)
0 Karma

venkatasri
SplunkTrust
SplunkTrust

Hi @victornajduch 

I am hoping 'neighbor' is correctly extracted. The lookup file could be sometimes having hidden chars not visible through normal text editors, you can try opening it using vi/vim/emacs editors to find and clear these chars.

---

An upvote would be appreciated and Accept  solution if this reply helps!

0 Karma

venkatasri
SplunkTrust
SplunkTrust
0 Karma

victornajduch
Loves-to-Learn Everything

@venkatasri checked for special characters and added a 3 (superfluous) column. No change.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...