Splunk Search

Is there a way to trim URL string from a table?

jrevolorio
Explorer

So, I want to create a table where it shows the time, source IP, and URL.

sourcetype=* src_ip=* url=* | table _time, src_ip, url

The search runs fine however the URL comes back with a long string.

Example= https://www.google.com/xxx_xxx?atyp=csi&ei=tWelWaipKMOJmQGb_Lr4Cg&s=newtab&action=update&ima=1&ime=0...

Is there a way to trim the string from the URL to only show up to google.com/xxx_xxx?

0 Karma
1 Solution

somesoni2
Revered Legend

Try like this

sourcetype=* src_ip=* url=* | table _time, src_ip, url | eval url=mvindex(split(url,"?"),0)

OR

sourcetype=* src_ip=* url=* | table _time, src_ip, url | rex field=url "^(?<url>[^\?]+)"

View solution in original post

niketn
Legend

You can also try replace() function with regular expression pattern

sourcetype=* src_ip=* url=* 
| table _time, src_ip, url 
| eval url=replace(url,"(^[^\?]+)(\?.*)","\1")
____________________________________________
| makeresults | eval message= "Happy Splunking!!!"
0 Karma

somesoni2
Revered Legend

Try like this

sourcetype=* src_ip=* url=* | table _time, src_ip, url | eval url=mvindex(split(url,"?"),0)

OR

sourcetype=* src_ip=* url=* | table _time, src_ip, url | rex field=url "^(?<url>[^\?]+)"

jrevolorio
Explorer

Thanks! Worked like a charm

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Agent Mode Engaged! Enchaining Agentic Operations with Splunk AI Assistant 2.0

    Are you ready to transform how your team handles complex data requests? We invite you to our upcoming ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Modernize your Splunk Apps – Introducing Python 3.13 in Splunk

We are excited to announce that the upcoming releases of Splunk Enterprise 10.2.x and Splunk Cloud Platform ...