Splunk Search

How to write a Splunk search for License Utilization for Particular events?

umesh
Path Finder

Hi ,

 

i want to find the license utilization of  firewall logs based on severity level. can anyone help me with the query on how to find the license utilization based on particular events like eventid in windows logs

Labels (5)
Tags (1)
0 Karma
1 Solution

richgalloway
SplunkTrust
SplunkTrust

Splunk's license usage log tracks utilization by index, host, source, sourcetype, and pool, but not severity.  You'll have to it yourself by adding up the sizes of all of the relevant events.  This method may not match the number calculated by Splunk, but should be close enough.

index=firewall sourcetype=firewall 
| eval size=len(_raw)
| stats sum(size) as TotalSize by severity
---
If this reply helps you, Karma would be appreciated.

View solution in original post

0 Karma

johnhuang
Motivator

You can approximate license utilization by counting the number of events instead of calculating the exact size. This is faster and could meet your use case.

For example, windows event log:

<base search>
| top 100 EventCode 

 

 

richgalloway
SplunkTrust
SplunkTrust

Splunk's license usage log tracks utilization by index, host, source, sourcetype, and pool, but not severity.  You'll have to it yourself by adding up the sizes of all of the relevant events.  This method may not match the number calculated by Splunk, but should be close enough.

index=firewall sourcetype=firewall 
| eval size=len(_raw)
| stats sum(size) as TotalSize by severity
---
If this reply helps you, Karma would be appreciated.
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Automating Threat Operations and Threat Hunting with Recorded Future

    Automating Threat Operations and Threat Hunting with Recorded Future June 29, 2026 | Register   Is your ...

Keep the Learning Going with the New Best of .conf Hub

Hello Splunkers, With .conf26 getting closer, there’s already a lot of excitement building around this year’s ...

Splunk Community Badges!

  Hey everyone! Ready to earn some serious bragging rights in the community? Along with our existing badges ...