Splunk Search

How to separate the fields AppDomainName and ApplicationSource in timechart?

lsy9891
Engager

Hi
I have this query that counts the number of errors for two applications but I get the application names from different fields-one from appdomainname and one from application source. I want these two different applications to display as two different lines in my chart. I tried this but it only shows EcomSubscription as a bar chart?

earliest=-1d@d latest=@d host="NETAPPA*" sourcetype="WinEventLog:Application" AND (AppDomainName= EcomSubscription.* OR ApplicationSource="/order*") AND "ErrorGUID" | eval application =  AppDomainName.":".ApplicationSource | timechart span=1h count BY application
0 Karma

Sukisen1981
Champion

|eval application = if (isnotnull(AppDomainName),AppDomainName,ApplicationSource) |timechart <..rest of the stuff>

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Data Outage Monitoring and Reporting

We’ve all been there, right? Living our best life, working on our Splunk environment, when out of nowhere a ...

Manage Datasets and Connections in Catalog on Splunk Cloud Platform

Set Up Data Where You Use It Catalog already helps teams find and understand data across Splunk indexes, ...

Persistent Queue at TcpOut — One of Splunk's Most Practical Features

Splunk introduced persistent queueing at the tcpout layer as one of the most practical resilience features in ...