Splunk Search

How to separate the fields AppDomainName and ApplicationSource in timechart?

lsy9891
Engager

Hi
I have this query that counts the number of errors for two applications but I get the application names from different fields-one from appdomainname and one from application source. I want these two different applications to display as two different lines in my chart. I tried this but it only shows EcomSubscription as a bar chart?

earliest=-1d@d latest=@d host="NETAPPA*" sourcetype="WinEventLog:Application" AND (AppDomainName= EcomSubscription.* OR ApplicationSource="/order*") AND "ErrorGUID" | eval application =  AppDomainName.":".ApplicationSource | timechart span=1h count BY application
0 Karma

Sukisen1981
Champion

|eval application = if (isnotnull(AppDomainName),AppDomainName,ApplicationSource) |timechart <..rest of the stuff>

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Make Your Machine Data AI-Ready in Splunk

Every team is getting ready for AI agents.   Thursday, November 12, 2026  |  11AM  PST / 2PM EST   ...

Splunk Asynchronous Forwarding Explained

Splunk asynchronous forwarding is often misunderstood as simply setting autoLBVolume. That is not quite right. ...

How to Monitor AI Agents with Splunk Agent Observability

Let’s say I’m running a travel planning AI app in production. A user asks for three concise hotel options in ...