Splunk Search

How to separate string with regex?

m0rt1f4g0
Explorer

Hi!

I would like to separate the field Privilegio

 

|---------------------------|-------------------------------------------------------------------------------------------|-------------|
|   src_user                      |      Privilegio                                                                                                                     |   count      |
|---------------------------|-------------------------------------------------------------------------------------------|-------------|
|   user-RAC0308$      | SeSecurityPrivilege                                                                                                      |    8127     |
|                                          |                                          SeBackupPrivilege                                                               |                    |
|                                          |                                          SeRestorePrivilege                                                               |                    |
|                                          |                                          SeTakeOwnershipPrivilege                                               |                    |
|                                          |                                          SeDebugPrivilege                                                                  |                    |
|                                          |                                          SeSystemEnvironmentPrivilege                                      |                    |
|                                          |                                          SeLoadDriverPrivilege                                                         |                    |
|                                          |                                          SeImpersonatePrivilege                                                      |                    |
|                                          |                                          SeDelegateSessionUserImpersonatePrivilege          |                    |
|                                          |                                          SeEnableDelegationPrivilege                                            |                    |
|                                          |                                          SeCreateTokenPrivilege                                                      |                    |
|                                          |                                          SeAssignPrimaryTokenPrivilege                                      |                     |
|---------------------------|--------------------------------------------------------------------------------------------|--------------|

 

Since it only counts the first value and the others are put with a tab, they are the windows privileges of the EventID 4672,  my query is the following:

index=oswinsec EventCode=4672
| stats values(PrivilegeList) as Privilegio count by src_user

m0rt1f4g0_0-1668840333515.png

 

Labels (5)
Tags (2)
0 Karma

ITWhisperer
SplunkTrust
SplunkTrust

Does this help?

index=oswinsec EventCode=4672
| stats count by src_user PrivilegeList
0 Karma

m0rt1f4g0
Explorer

@ITWhisperer Hi,

No, I think the field takes it as a single string

 

m0rt1f4g0_0-1668849973099.png

 

0 Karma

yuanliu
SplunkTrust
SplunkTrust

In that case, you need to split PrivilegeList first.

index=oswinsec EventCode=4672
| eval PrivilegeList = split(PrivilegeList, "
       ") ``` include the proper indentation characcter(s) ```
| eval SeSecurityPrivilege = mvindex(PrivilegeList, 1, mvcount(PrivilegeList))
``` the first line, SeSecurityPrivilege, is a mere header ```
| stats values(SeSecurityPrivilege) as Privilegio count by src_user

 

Tags (1)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

How Splunk AI Assistant Is Transforming Investigations: Insights from .conf26

At .conf26 in Denver, I spent much of my time in conversation with Splunk customers about Splunk AI Assistant. ...

Make Your Machine Data AI-Ready in Splunk

Every team is getting ready for AI agents.   Thursday, November 12, 2026  |  11AM  PST / 2PM EST   ...

Splunk Asynchronous Forwarding Explained

Splunk asynchronous forwarding is often misunderstood as simply setting autoLBVolume. That is not quite right. ...