Splunk Search

How to search windows interactive logon from the Authentication data model?

dbroggy
Path Finder

Hi there,

Is it possible to search for windows interactive logons from the Authentication data model?

eg. I can do it this way:

index=* source="*WinEventLog:Security" LogonType=2 OR LogonType=10 OR LogonType=11

And I'm looking for an equivalent way using a data model eg:

| tstats summariesonly=true count from datamodel=Authentication by Authentication.action Authentication.app Authentication.dest Authentication.signature Authentication.src Authentication.src_user Authentication.user
|search <SOME LOGIC>

Thank you!

Labels (1)
Tags (2)
0 Karma

VatsalJagani
SplunkTrust
SplunkTrust

@dbroggy - The Authentication data model does not have a field called "LogonType". 

  • You can clone the Authentication data model and add this additional field for your use case.

If this is the only query and performance is not a big problem I would suggest writing a regular query rather than creating a cloned version of data model as that will create additional search loads on Splunk servers.

If performance is a big problem you can use summary indexing or report acceleration as that would be much better for overall Splunk performance.

0 Karma

PickleRick
SplunkTrust
SplunkTrust

I don't see any fields in the datamodel which would map to the LogonType value. So you can't search for it from the existing datamodel. You'd have to make a copy of the datamodel and add new field to it.

But the question is whether there is a point since the CIM datamodels are meant to serve as a layer of abstraction separating the search using the datamodel from the gory details of particular data implementation. And your LogonType field is very implementation-specific. So from the data engineering point of view, it's not s pretty solution. If you want to have it only because you want to use data model acceleration, there are other ways to accelerate your searches.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

May 2026 Splunk Expert Sessions: Security & Observability

Level Up Your Operations: May 2026 Splunk Expert Sessions Whether you are refining your security posture or ...

Network to App: Observability Unlocked [May & June Series]

In today’s digital landscape, your environment is no longer confined to the data center. It spans complex ...

SPL2 Deep Dives, AppDynamics Integrations, SAML Made Simple and Much More on Splunk ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...