Splunk Search

How to get event _time from CIM data model?

phil_wong
Explorer

I checked CIM data models have inherited _time but I couldn't retrieve. 

Anyone can tell what's wrong? 

| tstats summariesonly=true allow_old_summaries=true count from datamodel=Network_Traffic.All_Traffic where All_Traffic.action=allowed by All_Traffic.src All_Traffic.dest All_Traffic._time

Labels (1)
Tags (2)
0 Karma
1 Solution

General_Talos
Path Finder

Thanks @scelikok 

@phil_wong 

Please note "_time,source, sourcetype and host" fields in datamodel  are default fields and doesn't require node_name in field-name

To get list of field name available in datamodel use

| datamodel <datamodel_name> search

 

View solution in original post

0 Karma

scelikok
SplunkTrust
SplunkTrust

Hi @phil_wong,

Metadata field are accessible without node name. You should use _time like below;

| tstats summariesonly=true allow_old_summaries=true count from datamodel=Network_Traffic.All_Traffic where All_Traffic.action=allowed by All_Traffic.src All_Traffic.dest _time

 

If this reply helps you an upvote is appreciated.

If this reply helps you an upvote and "Accept as Solution" is appreciated.
0 Karma

General_Talos
Path Finder

Thanks @scelikok 

@phil_wong 

Please note "_time,source, sourcetype and host" fields in datamodel  are default fields and doesn't require node_name in field-name

To get list of field name available in datamodel use

| datamodel <datamodel_name> search

 

0 Karma

phil_wong
Explorer

Just happend _time is not in the field list. So I was lost my mind.

Thanks for the suggestion!

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Vibe-coding, AI, and Splunkcraft: Highlights from the .conf26 Builder Bar

If you stopped by the Builder Bar at .conf26, thank you! This year, we brought ...

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...