Splunk Search

How to get event _time from CIM data model?

phil_wong
Explorer

I checked CIM data models have inherited _time but I couldn't retrieve. 

Anyone can tell what's wrong? 

| tstats summariesonly=true allow_old_summaries=true count from datamodel=Network_Traffic.All_Traffic where All_Traffic.action=allowed by All_Traffic.src All_Traffic.dest All_Traffic._time

Labels (1)
Tags (2)
0 Karma
1 Solution

General_Talos
Path Finder

Thanks @scelikok 

@phil_wong 

Please note "_time,source, sourcetype and host" fields in datamodel  are default fields and doesn't require node_name in field-name

To get list of field name available in datamodel use

| datamodel <datamodel_name> search

 

View solution in original post

0 Karma

scelikok
SplunkTrust
SplunkTrust

Hi @phil_wong,

Metadata field are accessible without node name. You should use _time like below;

| tstats summariesonly=true allow_old_summaries=true count from datamodel=Network_Traffic.All_Traffic where All_Traffic.action=allowed by All_Traffic.src All_Traffic.dest _time

 

If this reply helps you an upvote is appreciated.

If this reply helps you an upvote and "Accept as Solution" is appreciated.
0 Karma

General_Talos
Path Finder

Thanks @scelikok 

@phil_wong 

Please note "_time,source, sourcetype and host" fields in datamodel  are default fields and doesn't require node_name in field-name

To get list of field name available in datamodel use

| datamodel <datamodel_name> search

 

0 Karma

phil_wong
Explorer

Just happend _time is not in the field list. So I was lost my mind.

Thanks for the suggestion!

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Agent Mode Engaged! Enchaining Agentic Operations with Splunk AI Assistant 2.0

    Are you ready to transform how your team handles complex data requests? We invite you to our upcoming ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Modernize your Splunk Apps – Introducing Python 3.13 in Splunk

We are excited to announce that the upcoming releases of Splunk Enterprise 10.2.x and Splunk Cloud Platform ...