Splunk Search

How to disable typeahead

Path Finder

How do you disable typeahead? We want this turned off for all users by default.

Tags (1)
1 Solution

Motivator

Have you tried just editing the 'user' role and removing the capability?

In the Manager, go into Access Controls, choose Roles, and look under Selected Capabilities. You should see a capability called 'get_typeahead' -- remove it and Save.

Alternately, edit local/authorize.conf and add:

[role_user]
get_typeahead = disabled

You might have to do that on more than one role, but for most people it will just be inherited from the default user role.

View solution in original post

Motivator

Have you tried just editing the 'user' role and removing the capability?

In the Manager, go into Access Controls, choose Roles, and look under Selected Capabilities. You should see a capability called 'get_typeahead' -- remove it and Save.

Alternately, edit local/authorize.conf and add:

[role_user]
get_typeahead = disabled

You might have to do that on more than one role, but for most people it will just be inherited from the default user role.

View solution in original post